CVE-2024-13509

WS Form LITE and PRO <= 1.10.13 - Unauthenticated Stored Cross-Site Scripting

State
Published
Severity
7.2 High
Published
Jan 28, 2025
Updated
Apr 8, 2026
Reserved
Jan 17, 2025

Read the record on cve.org

Description

The WS Form LITE and PRO plugins for WordPress are vulnerable to Stored Cross-Site Scripting via the url parameter in all versions up to, and including, 1.10.13 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. NOTE: This vulnerability is partially fixed in 1.10.13 and completely fixed in 1.10.14.

Scores

CVSSScoreVectorSource
3.17.2 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:NWordfence

Weaknesses

  • CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Products

ProductVersions
WS Form LITE – Drag & Drop Contact Form Builderwestguard
  • 1.10.13 and earlierAffected
WS Form ProWS Form
  • 1.10.13 and earlierAffected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.