CVE-2024-13903

quickjs-ng QuickJS qjs quickjs.c JS_GetRuntime stack-based overflow

State
Published
Severity
5.3 Medium
Published
Mar 21, 2025
Updated
Mar 21, 2025
Reserved
Feb 23, 2025

Read the record on cve.org

Description

A vulnerability was found in quickjs-ng QuickJS up to 0.8.0. It has been declared as problematic. Affected by this vulnerability is the function JS_GetRuntime of the file quickjs.c of the component qjs. The manipulation leads to stack-based buffer overflow. The attack can be launched remotely. Upgrading to version 0.9.0 is able to address this issue. The patch is named 99c02eb45170775a9a679c32b45dd4000ea67aff. It is recommended to upgrade the affected component.

Scores

CVSSScoreVectorSource
4.05.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NVulDB
3.14.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:LVulDB
3.04.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:LVulDB
2.05.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:PVulDB

Weaknesses

Affected Products

ProductVersions
QuickJSquickjs-ng
  • 0.1Affected
  • 0.2Affected
  • 0.3Affected
  • 0.4Affected
  • 0.5Affected
  • 0.6Affected
  • 0.7Affected
  • 0.8Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.