CVE-2024-21733
Apache Tomcat: Leaking of unrelated request bodies in default error page
- State
- Published
- Severity
- 5.3 Medium
- Published
- Jan 19, 2024
- Updated
- Nov 3, 2025
- Reserved
- Jan 1, 2024
Description
Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat.This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Other, EOL versions may also be affected.
Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 5.3 Medium | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N | CISA-ADP |
Weaknesses
- CWE-209 Generation of Error Message Containing Sensitive Information
Affected Products
| Product | Versions |
|---|---|
Apache TomcatApache Software Foundation |
|
References
- https://lists.apache.org/thread/h9bjqdd0odj6lhs2o96qgowcc6hb0cfzvendor-advisory
- http://www.openwall.com/lists/oss-security/2024/01/19/2
- http://packetstormsecurity.com/files/176951/Apache-Tomcat-8.5.63-9.0.43-HTTP-Response-Smuggling.html
- https://security.netapp.com/advisory/ntap-20240216-0005/
- https://lists.debian.org/debian-lts-announce/2025/01/msg00009.html
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.