CVE-2024-22415

Unsecured endpoints in the jupyter-lsp server extension

State
Published
Severity
7.3 High
Published
Jan 18, 2024
Updated
Sep 10, 2024
Reserved
Jan 10, 2024

Read the record on cve.org

Description

jupyter-lsp is a coding assistance tool for JupyterLab (code navigation + hover suggestions + linters + autocompletion + rename) using Language Server Protocol. Installations of jupyter-lsp running in environments without configured file system access control (on the operating system level), and with jupyter-server instances exposed to non-trusted network are vulnerable to unauthorised access and modification of file system beyond the jupyter root directory. This issue has been patched in version 2.2.2 and all users are advised to upgrade. Users unable to upgrade should uninstall jupyter-lsp.

Scores

CVSSScoreVectorSource
3.17.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LGitHub_M

Weaknesses

  • CWE-23 Relative Path Traversal
  • CWE-284 Improper Access Control
  • CWE-306 Missing Authentication for Critical Function

Affected Products

ProductVersions
jupyterlab-lspjupyter-lsp
  • < 2.2.2Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.