CVE-2024-2339

Improper Input Validation in PostgreSQL Anonymizer 1.2 allows table owner to gain superuser privileges via masking rule

State
Published
Severity
8.0 High
Published
Mar 8, 2024
Updated
Aug 2, 2024
Reserved
Mar 8, 2024

Read the record on cve.org

Description

PostgreSQL Anonymizer v1.2 contains a vulnerability that allows a user who owns a table to elevate to superuser. A user can define a masking function for a column and place malicious code in that function. When a privileged user applies the masking rules using the static masking or the anonymous dump method, the malicious code is executed and can grant escalated privileges to the malicious user. PostgreSQL Anonymizer v1.2 does provide a protection against this risk with the restrict_to_trusted_schemas option, but that protection is incomplete. Users that don't own a table, especially masked users cannot exploit this vulnerability. The problem is resolved in v1.3.

Scores

CVSSScoreVectorSource
3.18.0 HighCVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:HPostgreSQL

Weaknesses

  • CWE-20 Improper Input Validation

Affected Products

ProductVersions
PostgreSQL AnonymizerDALIBO
  • 1 to before 1.3.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.