CVE-2024-2443

Improper input validation vulnerability was identified in GitHub Enterprise Server that allowed privilege escalation in the Management Console

State
Published
Severity
9.1 Critical
Published
Mar 20, 2024
Updated
Aug 27, 2024
Reserved
Mar 13, 2024

Read the record on cve.org

Description

A command injection vulnerability was identified in GitHub Enterprise Server that allowed an attacker with an editor role in the Management Console to gain admin SSH access to the appliance when configuring GeoJSON settings. Exploitation of this vulnerability required access to the GitHub Enterprise Server instance and access to the Management Console with the editor role. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.13 and was fixed in versions 3.8.17, 3.9.12, 3.10.9, 3.11.7, and 3.12.1. This vulnerability was reported via the GitHub Bug Bounty program.

Scores

CVSSScoreVectorSource
3.19.1 CriticalCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HGitHub_P

Weaknesses

  • CWE-20 Improper Input Validation

Affected Products

ProductVersions
GitHub Enterprise ServerGitHub
  • 3.8.0 to before 3.8.17Affectedfrom 3.8.17Not affected
  • 3.9.0 to before 3.9.12Affectedfrom 3.9.12Not affected
  • 3.10.0 to before 3.10.9Affectedfrom 3.10.9Not affected
  • 3.11.0 to before 3.11.7Affectedfrom 3.11.7Not affected
  • 3.12.0 to before 3.12.1Affectedfrom 3.12.1Not affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.