CVE-2024-24773

Apache Superset: Improper validation of SQL statements allows for unauthorized access to data

State
Published
Severity
4.9 Medium
Published
Feb 28, 2024
Updated
Feb 13, 2025
Reserved
Jan 30, 2024

Read the record on cve.org

Description

Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.

Users are recommended to upgrade to version 3.1.1, which fixes the issue.

Scores

CVSSScoreVectorSource
3.14.9 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:Napache

Weaknesses

Affected Products

ProductVersions
Apache SupersetApache Software Foundation
  • before 3.0.4Affected
  • 3.1.0 to before 3.1.1Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.