CVE-2024-28746
Apache Airflow: Ignored Airflow Permissions
- State
- Published
- Severity
- 8.1 High
- Published
- Mar 14, 2024
- Updated
- Mar 20, 2025
- Reserved
- Mar 8, 2024
Description
Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access.
Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 8.1 High | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N | CISA-ADP |
Weaknesses
- CWE-281 Improper Preservation of Permissions
Affected Products
| Product | Versions |
|---|---|
Apache AirflowApache Software Foundation |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.