CVE-2024-31862

Apache Zeppelin: Denial of service with invalid notebook name

State
Published
Severity
5.3 Medium
Published
Apr 9, 2024
Updated
Feb 13, 2025
Reserved
Apr 6, 2024

Read the record on cve.org

Description

Improper Input Validation vulnerability in Apache Zeppelin when creating a new note from Zeppelin's UI.This issue affects Apache Zeppelin: from 0.10.1 before 0.11.0.

Users are recommended to upgrade to version 0.11.0, which fixes the issue.

Scores

CVSSScoreVectorSource
3.15.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LCISA-ADP

Weaknesses

  • CWE-20 Improper Input Validation

Affected Products

ProductVersions
Apache ZeppelinApache Software Foundation
  • 0.10.1 to before 0.11.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.