CVE-2024-31866
Apache Zeppelin: Interpreter download command does not escape malicious code injection
- State
- Published
- Severity
- 9.8 Critical
- Published
- Apr 9, 2024
- Updated
- Feb 13, 2025
- Reserved
- Apr 6, 2024
Description
Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin.
The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1.
Users are recommended to upgrade to version 0.11.1, which fixes the issue.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 9.8 Critical | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | CISA-ADP |
Weaknesses
- CWE-116 Improper Encoding or Escaping of Output
Affected Products
| Product | Versions |
|---|---|
Apache ZeppelinApache Software Foundation |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.