CVE-2024-3204

c-blosc2 ndlz4x4.c ndlz4_decompress heap-based overflow

State
Published
Severity
7.3 High
Published
Apr 2, 2024
Updated
Aug 1, 2024
Reserved
Apr 2, 2024

Read the record on cve.org

Description

A vulnerability has been found in c-blosc2 up to 2.13.2 and classified as critical. Affected by this vulnerability is the function ndlz4_decompress of the file /src/c-blosc2/plugins/codecs/ndlz/ndlz4x4.c. The manipulation leads to heap-based buffer overflow. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.14.3 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-259051.

Scores

CVSSScoreVectorSource
3.17.3 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LVulDB
3.07.3 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LVulDB
2.07.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:PVulDB

Weaknesses

Affected Products

ProductVersions
c-blosc2n/a
  • 2.13.0Affected
  • 2.13.1Affected
  • 2.13.2Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.