CVE-2024-32638

Apache APISIX: Forward-Auth Request Smuggling

State
Published
Severity
6.3 Medium
Published
May 2, 2024
Updated
Feb 13, 2025
Reserved
Apr 16, 2024

Read the record on cve.org

Description

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0.

Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.

Scores

CVSSScoreVectorSource
3.16.3 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LCISA-ADP

Weaknesses

  • CWE-444 Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling')

Affected Products

ProductVersions
Apache APISIXApache Software Foundation
  • 3.8.0 through 3.9.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.