CVE-2024-3379
Incorrect Authorization in lunary-ai/lunary
- State
- Published
- Severity
- 9.6 Critical
- Published
- Nov 14, 2024
- Updated
- Nov 18, 2024
- Reserved
- Apr 5, 2024
Description
In lunary-ai/lunary versions 1.2.2 through 1.2.6, an incorrect authorization vulnerability allows unprivileged users to re-generate the private key for projects they do not have access to. Specifically, a user with a 'Member' role can issue a request to regenerate the private key of a project without having the necessary permissions or being assigned to that project. This issue was fixed in version 1.2.7.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.0 | 9.6 Critical | CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N | @huntr_ai |
| 3.1 | 9.6 Critical | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N | CISA-ADP |
Weaknesses
- CWE-863 Incorrect Authorization
Affected Products
| Product | Versions |
|---|---|
lunary-ai/lunarylunary-ai |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.