CVE-2024-3504
Improper Access Control in lunary-ai/lunary
- State
- Published
- Severity
- 8.1 High
- Published
- Jun 6, 2024
- Updated
- Oct 15, 2025
- Reserved
- Apr 9, 2024
Description
An improper access control vulnerability exists in lunary-ai/lunary versions up to and including 1.2.2, where an admin can update any organization user to the organization owner. This vulnerability allows the elevated user to delete projects within the organization. The issue is resolved in version 1.2.7.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.0 | 8.1 High | CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H | @huntr_ai |
Weaknesses
- CWE-863 Incorrect Authorization
Affected Products
| Product | Versions |
|---|---|
lunary-ai/lunarylunary-ai |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.