CVE-2024-35164
Apache Guacamole: Improper input validation of console codes
- State
- Published
- Severity
- 6.8 Medium
- Published
- Jul 2, 2025
- Updated
- Feb 26, 2026
- Reserved
- May 10, 2024
Description
The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed with the privileges of the running guacd process.
Users are recommended to upgrade to version 1.6.0, which fixes this issue.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 6.8 Medium | CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N | apache |
Weaknesses
- CWE-129 Improper Validation of Array Index
Affected Products
| Product | Versions |
|---|---|
Apache GuacamoleApache Software Foundation |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.