CVE-2024-37162

zsa Generates Error Messages Containing Sensitive Information

State
Published
Severity
4.0 Medium
Published
Jun 7, 2024
Updated
Aug 2, 2024
Reserved
Jun 3, 2024

Read the record on cve.org

Description

zsa is a library for building typesafe server actions in Next.js. All users are impacted. The zsa application transfers the parse error stack from the server to the client in production build mode. This can potentially reveal sensitive information about the server environment, such as the machine username and directory paths. An attacker could exploit this vulnerability to gain unauthorized access to sensitive server information. This information could be used to plan further attacks or gain a deeper understanding of the server infrastructure. This has been patched on `0.3.3`.

Scores

CVSSScoreVectorSource
3.14.0 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:NGitHub_M

Weaknesses

  • CWE-209 Generation of Error Message Containing Sensitive Information

Affected Products

ProductVersions
zsaIdoPesok
  • < 0.3.3Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.