CVE-2024-37294

Aimeos denial of service vulnerability in SaaS and marketplace setups

State
Published
Severity
5.5 Medium
Published
Jun 11, 2024
Updated
Aug 2, 2024
Reserved
Jun 5, 2024

Read the record on cve.org

Description

Aimeos is an Open Source e-commerce framework for online shops. All SaaS and marketplace setups using Aimeos version from 2022/2023/2024 are affected by a potential denial of service attack. Users should upgrade to versions 2022.10.17, 2023.10.17, or 2024.04 of the aimeos/aimeos-core package to receive a patch.

Scores

CVSSScoreVectorSource
3.15.5 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:HGitHub_M

Weaknesses

  • CWE-270 Privilege Context Switching Error

Affected Products

ProductVersions
aimeos-coreaimeos
  • >= 2024.04.1, < 2024.04.7Affected
  • >= 2023.04.1, < 2023.10.17Affected
  • >= 2022.04.1, < 2022.10.17Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.