CVE-2024-3761

Missing Authorization on Delete Datasets in lunary-ai/lunary

State
Published
Severity
9.1 Critical
Published
May 20, 2024
Updated
Aug 1, 2024
Reserved
Apr 13, 2024

Read the record on cve.org

Description

In lunary-ai/lunary version 1.2.2, the DELETE endpoint located at `packages/backend/src/api/v1/datasets` is vulnerable to unauthorized dataset deletion due to missing authorization and authentication mechanisms. This vulnerability allows any user, even those without a valid token, to delete a dataset by sending a DELETE request to the endpoint. The issue was fixed in version 1.2.8. The impact of this vulnerability is significant as it permits unauthorized users to delete datasets, potentially leading to data loss or disruption of service.

Scores

CVSSScoreVectorSource
3.09.1 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H@huntr_ai

Weaknesses

Affected Products

ProductVersions
lunary-ai/lunarylunary-ai
  • before 1.2.8Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.