CVE-2024-38473

Apache HTTP Server proxy encoding problem

State
Published
Severity
8.1 High
Published
Jul 1, 2024
Updated
Feb 13, 2025
Reserved
Jun 17, 2024

Read the record on cve.org

Description

Encoding problem in mod_proxy in Apache HTTP Server 2.4.59 and earlier allows request URLs with incorrect encoding to be sent to backend services, potentially bypassing authentication via crafted requests. Users are recommended to upgrade to version 2.4.60, which fixes this issue.

Scores

CVSSScoreVectorSource
3.18.1 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:HCISA-ADP

Weaknesses

  • CWE-116 Improper Encoding or Escaping of Output

Affected Products

ProductVersions
Apache HTTP ServerApache Software Foundation
  • 2.4.0 through 2.4.59Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.