CVE-2024-39308

RailsAdmin Cross-site Scripting vulnerability in the list view

State
Published
Severity
6.8 Medium
Published
Jul 8, 2024
Updated
Aug 2, 2024
Reserved
Jun 21, 2024

Read the record on cve.org

Description

RailsAdmin is a Rails engine that provides an interface for managing data. RailsAdmin list view has the XSS vulnerability, caused by improperly-escaped HTML title attribute. Upgrade to 3.1.3 or 2.2.2 (to be released).

Scores

CVSSScoreVectorSource
3.06.8 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:NGitHub_M

Weaknesses

  • CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Products

ProductVersions
rails_adminrailsadminteam
  • >= 3.0.0, < 3.1.3Affected
  • < 2.3.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.