CVE-2024-39320
Discourse allows iframe injection though default site setting
- State
- Published
- Severity
- 6.1 Medium
- Published
- Jul 30, 2024
- Updated
- Aug 2, 2024
- Reserved
- Jun 21, 2024
Description
Discourse is an open source discussion platform. Prior to 3.2.5 and 3.3.0.beta5, the vulnerability allows an attacker to inject iframes from any domain, bypassing the intended restrictions enforced by the allowed_iframes setting. This vulnerability is fixed in 3.2.5 and 3.3.0.beta5.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 6.1 Medium | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N | GitHub_M |
Weaknesses
Affected Products
| Product | Versions |
|---|---|
discoursediscourse |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.