CVE-2024-41676

Magento LTS vulnerable to stored Cross-site Scripting (XSS) in admin system configs

State
Published
Severity
4.1 Medium
Published
Jul 29, 2024
Updated
Aug 2, 2024
Reserved
Jul 18, 2024

Read the record on cve.org

Description

Magento-lts is a long-term support alternative to Magento Community Edition (CE). This XSS vulnerability affects the design/header/welcome, design/header/logo_src, design/header/logo_src_small, and design/header/logo_alt system configs.They are intended to enable admins to set a text in the two cases, and to define an image url for the other two cases. But because of previously missing escaping allowed to input arbitrary html and as a consequence also arbitrary JavaScript. The problem is patched with Version 20.10.1 or higher.

Scores

CVSSScoreVectorSource
3.14.1 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:L/A:NGitHub_M

Weaknesses

  • CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Affected Products

ProductVersions
magento-ltsOpenMage
  • < 20.10.1Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.