CVE-2024-4181

Command Injection in run-llama/llama_index

State
Published
Severity
8.8 High
Published
May 16, 2024
Updated
Aug 1, 2024
Reserved
Apr 25, 2024

Read the record on cve.org

Description

A command injection vulnerability exists in the RunGptLLM class of the llama_index library, version 0.9.47, used by the RunGpt framework from JinaAI to connect to Language Learning Models (LLMs). The vulnerability arises from the improper use of the eval function, allowing a malicious or compromised LLM hosting provider to execute arbitrary commands on the client's machine. This issue was fixed in version 0.10.13. The exploitation of this vulnerability could lead to a hosting provider gaining full control over client machines.

Scores

CVSSScoreVectorSource
3.08.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H@huntr_ai

Weaknesses

  • CWE-94 Improper Control of Generation of Code

Affected Products

ProductVersions
run-llama/llama_indexrun-llama
  • before 0.10.13Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.