CVE-2024-41964

Insufficient permission checks in the language settings in Kirby CMS

State
Published
Severity
8.1 High
Published
Aug 29, 2024
Updated
Aug 29, 2024
Reserved
Jul 24, 2024

Read the record on cve.org

Description

Kirby is a CMS targeting designers and editors. Kirby allows to restrict the permissions of specific user roles. Users of that role can only perform permitted actions. Permissions for creating and deleting languages have already existed and could be configured, but were not enforced by Kirby's frontend or backend code. A permission for updating existing languages has not existed before the patched versions. So disabling the languages.* wildcard permission for a role could not have prohibited updates to existing language definitions. The missing permission checks allowed attackers with Panel access to manipulate the language definitions. The problem has been patched in Kirby 3.6.6.6, Kirby 3.7.5.5, Kirby 3.8.4.4, Kirby 3.9.8.2, Kirby 3.10.1.1, and Kirby 4.3.1. Please update to one of these or a later version to fix the vulnerability. There are no known workarounds for this vulnerability.

Scores

CVSSScoreVectorSource
3.18.1 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:HGitHub_M

Weaknesses

Affected Products

ProductVersions
kirbygetkirby
  • < 3.6.6.6Affected
  • >= 3.7.0, < 3.7.5.5Affected
  • >= 3.8.0, < 3.8.4.4Affected
  • >= 3.9.0, < 3.9.8.2Affected
  • >= 3.10.0, < 3.10.1.1Affected
  • >= 4.0.0, < 4.3.1Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.