CVE-2024-43115

Apache DolphinScheduler: Alert Script Attack

State
Published
Severity
8.8 High
Published
Sep 3, 2025
Updated
Nov 4, 2025
Reserved
Aug 7, 2024

Read the record on cve.org

Description

Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can execute any shell script server by alert script.

This issue affects Apache DolphinScheduler: before 3.2.2.

Users are recommended to upgrade to version 3.3.1, which fixes the issue.

Scores

CVSSScoreVectorSource
3.18.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HCISA-ADP

Weaknesses

  • CWE-20 Improper Input Validation

Affected Products

ProductVersions
Apache DolphinSchedulerApache Software Foundation
  • before 3.2.2Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.