CVE-2024-45719
Apache Answer: Predictable Authorization Token Using UUIDv1
- State
- Published
- Severity
- 2.6 Low
- Published
- Nov 22, 2024
- Updated
- Nov 22, 2024
- Reserved
- Sep 5, 2024
Description
Inadequate Encryption Strength vulnerability in Apache Answer.
This issue affects Apache Answer: through 1.4.0.
The ids generated using the UUID v1 version are to some extent not secure enough. It can cause the generated token to be predictable. Users are recommended to upgrade to version 1.4.1, which fixes the issue.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 2.6 Low | CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:N/A:N | CISA-ADP |
Weaknesses
- CWE-326 Inadequate Encryption Strength
Affected Products
| Product | Versions |
|---|---|
Apache AnswerApache Software Foundation |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.