CVE-2024-45772
Apache Lucene Replicator: Security Vulnerability in Lucene Replicator - Deserialization Issue
- State
- Published
- Severity
- 5.1 Medium
- Published
- Sep 30, 2024
- Updated
- Dec 12, 2024
- Reserved
- Sep 7, 2024
Description
Deserialization of Untrusted Data vulnerability in Apache Lucene Replicator.
This issue affects Apache Lucene's replicator module: from 4.4.0 before 9.12.0. The deprecated org.apache.lucene.replicator.http package is affected. The org.apache.lucene.replicator.nrt package is not affected.
Users are recommended to upgrade to version 9.12.0, which fixes the issue.
The deserialization can only be triggered if users actively deploy an network-accessible implementation and a corresponding client using a HTTP library that uses the API (e.g., a custom servlet and HTTPClient). Java serialization filters (such as -Djdk.serialFilter='!*' on the commandline) can mitigate the issue on vulnerable versions without impacting functionality.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 5.1 Medium | CVSS:3.1/AV:A/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L | apache |
Weaknesses
- CWE-502 Deserialization of Untrusted Data
Affected Products
| Product | Versions |
|---|---|
Apache Lucene ReplicatorApache Software Foundation |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.