CVE-2024-47081

Requests vulnerable to .netrc credentials leak via malicious URLs

State
Published
Severity
5.3 Medium
Published
Jun 9, 2025
Updated
Jun 9, 2025
Reserved
Sep 17, 2024

Read the record on cve.org

Description

Requests is a HTTP library. Due to a URL parsing issue, Requests releases prior to 2.32.4 may leak .netrc credentials to third parties for specific maliciously-crafted URLs. Users should upgrade to version 2.32.4 to receive a fix. For older versions of Requests, use of the .netrc file can be disabled with `trust_env=False` on one's Requests Session.

Scores

CVSSScoreVectorSource
3.15.3 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:NGitHub_M

Weaknesses

  • CWE-522 Insufficiently Protected Credentials

Affected Products

ProductVersions
requestspsf
  • < 2.32.4Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.