CVE-2024-5126
Improper Access Control in lunary-ai/lunary
- State
- Published
- Severity
- 7.6 High
- Published
- Jun 6, 2024
- Updated
- Oct 15, 2025
- Reserved
- May 19, 2024
Description
An improper access control vulnerability exists in the lunary-ai/lunary repository, specifically within the versions.patch functionality for updating prompts. Affected versions include 1.2.2 up to but not including 1.2.25. The vulnerability allows unauthorized users to update prompt details due to insufficient access control checks. This issue was addressed and fixed in version 1.2.25.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.0 | 7.6 High | CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L | @huntr_ai |
Weaknesses
- CWE-862 Missing Authorization
Affected Products
| Product | Versions |
|---|---|
lunary-ai/lunarylunary-ai |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.