CVE-2024-53948

Apache Superset: Error verbosity exposes metadata in analytics databases

State
Published
Severity
5.3 Medium
Published
Dec 9, 2024
Updated
Dec 9, 2024
Reserved
Nov 25, 2024

Read the record on cve.org

Description

Generation of Error Message Containing analytics metadata Information in Apache Superset.

This issue affects Apache Superset: before 4.1.0.

Users are recommended to upgrade to version 4.1.0, which fixes the issue.

Scores

CVSSScoreVectorSource
4.05.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:Napache

Weaknesses

  • CWE-209 Generation of Error Message Containing Sensitive Information

Affected Products

ProductVersions
Apache SupersetApache Software Foundation
  • before 4.1.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.