CVE-2024-53949

Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabled

State
Published
Severity
7.6 High
Published
Dec 9, 2024
Updated
Feb 12, 2025
Reserved
Nov 25, 2024

Read the record on cve.org

Description

Improper Authorization vulnerability in Apache Superset when FAB_ADD_SECURITY_API is enabled (disabled by default). Allows for lower privilege users to use this API.

issue affects Apache Superset: from 2.0.0 before 4.1.0.

Users are recommended to upgrade to version 4.1.0, which fixes the issue.

Scores

CVSSScoreVectorSource
4.07.6 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:Napache

Weaknesses

Affected Products

ProductVersions
Apache SupersetApache Software Foundation
  • 2.0.0 to before 4.1.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.