CVE-2024-54141

phpMyFAQ Generates an Error Message Containing Sensitive Information if database server is not available

State
Published
Severity
8.6 High
Published
Dec 6, 2024
Updated
Dec 6, 2024
Reserved
Nov 29, 2024

Read the record on cve.org

Description

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Prior to 4.0.0, phpMyFAQ exposes the database (ie postgreSQL) server's credential when connection to DB fails. This vulnerability is fixed in 4.0.0.

Scores

CVSSScoreVectorSource
3.18.6 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:LGitHub_M

Weaknesses

  • CWE-209 Generation of Error Message Containing Sensitive Information

Affected Products

ProductVersions
phpMyFAQthorsten
  • < 4.0.0Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.