CVE-2024-7055

FFmpeg pnmdec.c pnm_decode_frame heap-based overflow

State
Published
Severity
6.9 Medium
Published
Aug 6, 2024
Updated
Nov 3, 2025
Reserved
Jul 23, 2024

Read the record on cve.org

Description

A vulnerability was found in FFmpeg up to 7.0.1. It has been classified as critical. This affects the function pnm_decode_frame in the library /libavcodec/pnmdec.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 7.0.2 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-273651.

Scores

CVSSScoreVectorSource
4.06.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:NVulDB
3.16.3 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:LVulDB
3.06.3 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:LVulDB
2.07.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:PVulDB

Weaknesses

Affected Products

ProductVersions
FFmpegn/a
  • 7.0.0Affected
  • 7.0.1Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.