CVE-2024-8263

State
Published
Severity
6.2 Medium
Published
Sep 23, 2024
Updated
Sep 23, 2024
Reserved
Aug 28, 2024

Read the record on cve.org

Description

An improper privilege management vulnerability allowed arbitrary workflows to be committed using an improperly scoped PAT through the use of nested tags. This vulnerability affected all versions of GitHub Enterprise Server and was fixed in version 3.10.17, 3.11.15, 3.12.9, 3.13.4, and 3.14.1. This vulnerability was reported via the GitHub Bug Bounty program.

Scores

CVSSScoreVectorSource
4.06.2 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:L/SI:H/SA:NGitHub_P

Weaknesses

  • CWE-269 Improper Privilege Management

Affected Products

ProductVersions
GitHub Enterprise ServerGitHub
  • 3.14 through 3.14.0Affectedfrom 3.14.1Not affected
  • 3.13.0 through 3.13.3Affectedfrom 3.13.4Not affected
  • 3.12.0 through 3.12.8Affectedfrom 3.12.9Not affected
  • 3.11.0 through 3.11.14Affectedfrom 3.11.15Not affected
  • 3.10.0 through 3.10.16Affectedfrom 3.10.17Not affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.