CVE-2024-9847

Cross-Site Request Forgery (CSRF) in flatpressblog/flatpress

State
Published
Severity
8.0 High
Published
Mar 20, 2025
Updated
Mar 20, 2025
Reserved
Oct 10, 2024

Read the record on cve.org

Description

FlatPress CMS version latest is vulnerable to Cross-Site Request Forgery (CSRF) attacks that allow an attacker to enable or disable plugins on behalf of a victim user. The attacker can craft a malicious link or script that, when clicked by an authenticated user, will send a request to the FlatPress CMS server to perform the desired action on behalf of the victim user. Since the request is authenticated, the server will process it as if it were initiated by the legitimate user, effectively allowing the attacker to perform unauthorized actions. This vulnerability is fixed in version 1.4.dev.

Scores

CVSSScoreVectorSource
3.08.0 HighCVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H@huntr_ai

Weaknesses

  • CWE-352 Cross-Site Request Forgery (CSRF)

Affected Products

ProductVersions
flatpressblog/flatpressflatpressblog
  • before 1.4.devAffected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.