CVE-2025-0914
Velociraptor Shell Plugin Prevent_execve Bypass
- State
- Published
- Severity
- 3.8 Low
- Published
- Feb 27, 2025
- Updated
- Feb 27, 2025
- Reserved
- Jan 30, 2025
Description
An improper access control issue in the VQL shell feature in Velociraptor Versions < 0.73.4 allowed authenticated users to execute the execve() plugin in deployments where this was explicitly forbidden by configuring the prevent_execve flag in the configuration file. This setting is not usually recommended and is uncommonly used, so this issue will only affect users who do set it. This issue is fixed in release 0.73.4.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 3.8 Low | CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N | rapid7 |
Weaknesses
- CWE-281 Improper Preservation of Permissions
Affected Products
| Product | Versions |
|---|---|
VelociraptorRapid7 |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.