CVE-2025-10360

Insufficiently Protected Credentials in Puppet Enterprise 2025.4 and 2025.5

State
Published
Severity
6.9 Medium
Published
Sep 24, 2025
Updated
Sep 24, 2025
Reserved
Sep 12, 2025

Read the record on cve.org

Description

In Puppet Enterprise versions 2025.4.0 and 2025.5, the encryption key used for encrypting content in the Infra Assistant database was not excluded from the files gathered by Puppet backup. The key is only present on the system if the user has a Puppet Enterprise Advanced license and has enabled the Infra Assistant feature. The key is used for encrypting one particular bit of data in the Infra Assistant database: the API key for their AI provider account. This has been fixed in Puppet Enterprise version 2025.6, and release notes for 2025.6 have remediation steps for users of affected versions who can't update to the latest version.

Scores

CVSSScoreVectorSource
4.06.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:L/SI:L/SA:NPerforce

Weaknesses

  • CWE-522 Insufficiently Protected Credentials

Affected Products

ProductVersions
Puppet EnterprisePerforce
  • 2025.4 through 2025.5Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.