CVE-2025-14280
PixelYourSite <= 11.1.5 - Sensitive Information Exposure via Log File
- State
- Published
- Severity
- 5.3 Medium
- Published
- Dec 29, 2025
- Updated
- Apr 8, 2026
- Reserved
- Dec 8, 2025
Description
The PixelYourSite plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 11.1.5 through publicly exposed log files. This makes it possible for unauthenticated attackers to view potentially sensitive information contained in the exposed log files, when the "Meta API logs" setting is enabled (disabled by default). The vulnerability was partially patched in version 11.1.5 and fully patched in version 11.1.5.1.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 5.3 Medium | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N | Wordfence |
Weaknesses
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor
Affected Products
| Product | Versions |
|---|---|
PixelYourSite – Your smart PIXEL (TAG) & API Managerpixelyoursite |
|
References
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0fe77926-8a43-42ce-9d3d-3aac2334dcbd?source=cve
- https://plugins.trac.wordpress.org/browser/pixelyoursite/tags/11.1.4.2/includes/logger/class-pys-logger.php#L118
- https://plugins.trac.wordpress.org/changeset/3424175/pixelyoursite
- https://plugins.trac.wordpress.org/changeset/3416113/pixelyoursite
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.