CVE-2025-29927

Authorization Bypass in Next.js Middleware

State
Published
Severity
9.1 Critical
Published
Mar 21, 2025
Updated
Apr 8, 2025
Reserved
Mar 12, 2025

Read the record on cve.org

Description

Next.js is a React framework for building full-stack web applications. Starting in version 1.11.4 and prior to versions 12.3.5, 13.5.9, 14.2.25, and 15.2.3, it is possible to bypass authorization checks within a Next.js application, if the authorization check occurs in middleware. If patching to a safe version is infeasible, it is recommend that you prevent external user requests which contain the x-middleware-subrequest header from reaching your Next.js application. This vulnerability is fixed in 12.3.5, 13.5.9, 14.2.25, and 15.2.3.

Scores

CVSSScoreVectorSource
3.19.1 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NGitHub_M

Weaknesses

Affected Products

ProductVersions
next.jsvercel
  • >= 11.1.4, < 12.3.5Affected
  • >= 14.0.0, < 14.2.25Affected
  • >= 15.0.0, < 15.2.3Affected
  • >= 13.0.0, < 13.5.9Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.