CVE-2025-30151

Shopware allows Denial Of Service via password length

State
Published
Severity
7.5 High
Published
Apr 8, 2025
Updated
Apr 8, 2025
Reserved
Mar 17, 2025

Read the record on cve.org

Description

Shopware is an open commerce platform. It's possible to pass long passwords that leads to Denial Of Service via forms in Storefront forms or Store-API. This vulnerability is fixed in 6.6.10.3 or 6.5.8.17. For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.

Scores

CVSSScoreVectorSource
3.17.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HGitHub_M

Weaknesses

  • CWE-20 Improper Input Validation

Affected Products

ProductVersions
shopwareshopware
  • < 6.5.8.17Affected
  • >= 6.6.0.0, < 6.6.10.3Affected
  • >= 6.7.0.0-rc1, < 6.7.0.0-rc2Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.