CVE-2025-31480

aiven-extras allows PostgreSQL Privilege Escalation through format function

State
Published
Severity
9.1 Critical
Published
Apr 4, 2025
Updated
Apr 4, 2025
Reserved
Mar 28, 2025

Read the record on cve.org

Description

aiven-extras is a PostgreSQL extension. This is a privilege escalation vulnerability, allowing elevation to superuser inside PostgreSQL databases that use the aiven-extras package. The vulnerability leverages the format function not being schema-prefixed. Affected users should install 1.1.16 and ensure they run the latest version issuing ALTER EXTENSION aiven_extras UPDATE TO '1.1.16' after installing it. This needs to happen in each database aiven_extras has been installed in.

Scores

CVSSScoreVectorSource
3.19.1 CriticalCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HGitHub_M

Weaknesses

Affected Products

ProductVersions
aiven-extrasaiven
  • < 1.1.16Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.