CVE-2025-32444

vLLM Vulnerable to Remote Code Execution via Mooncake Integration

State
Published
Severity
10.0 Critical
Published
Apr 30, 2025
Updated
Apr 30, 2025
Reserved
Apr 8, 2025

Read the record on cve.org

Description

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Versions starting from 0.6.5 and prior to 0.8.5, having vLLM integration with mooncake, are vulnerable to remote code execution due to using pickle based serialization over unsecured ZeroMQ sockets. The vulnerable sockets were set to listen on all network interfaces, increasing the likelihood that an attacker is able to reach the vulnerable ZeroMQ sockets to carry out an attack. vLLM instances that do not make use of the mooncake integration are not vulnerable. This issue has been patched in version 0.8.5.

Scores

CVSSScoreVectorSource
3.110.0 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:HGitHub_M

Weaknesses

  • CWE-502 Deserialization of Untrusted Data

Affected Products

ProductVersions
vllmvllm-project
  • >= 0.6.5, < 0.8.5Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.