CVE-2025-34115
OP5 Monitor <= 7.1.9 Authenticated Command Execution via command_test.php
- State
- Published
- Severity
- 8.7 High
- Published
- Jul 15, 2025
- Updated
- Sep 8, 2026
- Reserved
- Apr 15, 2025
Description
An authenticated command injection vulnerability exists in OP5 Monitor through version 7.1.9 via the 'cmd_str' parameter in the command_test.php endpoint. A user with access to the web interface can exploit the 'Test this command' feature to execute arbitrary shell commands as the unprivileged web application user. The vulnerability resides in the configuration section of the application and requires valid login credentials with access to the command testing functionality. This issue is fixed in version 7.2.0.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 8.7 High | CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N | VulnCheck |
Weaknesses
Affected Products
| Product | Versions |
|---|---|
OP5 MonitorITRS Group |
|
References
- https://raw.githubusercontent.com/rapid7/metasploit-framework/master/modules/exploits/linux/http/op5_config_exec.rbexploit
- https://www.exploit-db.com/exploits/39676exploit
- https://www.itrsgroup.com/products/network-monitoring-op5-monitorproduct
- https://www.vulncheck.com/advisories/op5-monitor-authenticated-command-executionthird-party-advisory
- http://seclists.org/fulldisclosure/2026/Sep/38
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.