CVE-2025-3744

Nomad Vulnerable To Violation Of Mandatory Sentinel Policies in Nomad Job Submissions via Policy Override

State
Published
Severity
7.6 High
Published
May 13, 2025
Updated
May 13, 2025
Reserved
Apr 16, 2025

Read the record on cve.org

Description

Nomad Enterprise (“Nomad”) jobs using the policy override option are bypassing the mandatory sentinel policies. This vulnerability, identified as CVE-2025-3744, is fixed in Nomad Enterprise 1.10.1, 1.9.9, and 1.8.13.

Scores

CVSSScoreVectorSource
3.17.6 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:LHashiCorp

Weaknesses

  • CWE-266 Incorrect Privilege Assignment

Affected Products

ProductVersions
Nomad EnterpriseHashiCorp
  • before 1.10.1Affectedfrom 1.9.9Not affectedfrom 1.8.13Not affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.