CVE-2025-46349
YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting
- State
- Published
- Severity
- 7.6 High
- Published
- Apr 29, 2025
- Updated
- Apr 29, 2025
- Reserved
- Apr 22, 2025
Description
YesWiki is a wiki system written in PHP. Prior to version 4.5.4, YesWiki is vulnerable to reflected XSS in the file upload form. This vulnerability allows any malicious unauthenticated user to create a link that can be clicked on by the victim to perform arbitrary actions. This issue has been patched in version 4.5.4.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 7.6 High | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:L | GitHub_M |
Weaknesses
- CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected Products
| Product | Versions |
|---|---|
yeswikiYesWiki |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.