CVE-2025-46823
OpenMRS has Vulnerability in FHIR2 Module Privileges
- State
- Published
- Severity
- 8.0 High
- Published
- May 29, 2025
- Updated
- May 29, 2025
- Reserved
- Apr 30, 2025
Description
openmrs-module-fhir2 provides the FHIR REST API and related services for OpenMRS, an open medical records system. In versions of the FHIR2 module prior to 2.5.0, privileges were not always correctly checked, which means that unauthorized users may have been able to add or edit data they were not supposed to be able to. All implementers should update to FHIR2 2.5.0 or newer as soon as is feasible to receive a patch.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 8.0 High | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U | GitHub_M |
Weaknesses
- CWE-862 Missing Authorization
Affected Products
| Product | Versions |
|---|---|
openmrs-module-fhir2openmrs |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.