CVE-2025-48386

Git allows a buffer overflow in 'wincred' credential helper

State
Published
Severity
6.3 Medium
Published
Jul 8, 2025
Updated
Nov 4, 2025
Reserved
May 19, 2025

Read the record on cve.org

Description

Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. The wincred credential helper uses a static buffer (target) as a unique key for storing and comparing against internal storage. This credential helper does not properly bounds check the available space remaining in the buffer before appending to it with wcsncat(), leading to potential buffer overflows. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.

Scores

CVSSScoreVectorSource
3.16.3 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:NGitHub_M

Weaknesses

  • CWE-120 Buffer Copy without Checking Size of Input ('Classic Buffer Overflow')

Affected Products

ProductVersions
gitgit
  • < 2.43.7Affected
  • >= 2.44.0-rc0, < 2.44.4Affected
  • >= 2.45.0-rc0, < 2.45.4Affected
  • >= 2.46.0-rc0, < 2.46.4Affected
  • >= 2.47.0-rc0, < 2.47.3Affected
  • >= 2.48.0-rc0, < 2.48.2Affected
  • >= 2.49.0-rc0, < 2.49.1Affected
  • >= 2.50.0-rc0, < 2.50.1Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.