CVE-2025-48877
Discourse vulnerable to auto-executing of third-party code in embedded CodePen iframe
- State
- Published
- Severity
- 8.1 High
- Published
- Jun 9, 2025
- Updated
- Jun 9, 2025
- Reserved
- May 27, 2025
Description
Discourse is an open-source discussion platform. Prior to version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch, Codepen is present in the default `allowed_iframes` site setting, and it can potentially auto-run arbitrary JS in the iframe scope, which is unintended. This issue is patched in version 3.4.4 of the `stable` branch, version 3.5.0.beta5 of the `beta` branch, and version 3.5.0.beta6-dev of the `tests-passed` branch. As a workaround, the Codepen prefix can be removed from a site's `allowed_iframes`.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 4.0 | 8.1 High | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U | GitHub_M |
Weaknesses
- CWE-1038 Insecure Automated Optimizations
Affected Products
| Product | Versions |
|---|---|
discoursediscourse |
|
References
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.