CVE-2025-49506

Apache Portable Runtime Utility: apr_password_validate() vulnerable to timing attack

State
Published
Severity
7.5 High
Published
Aug 6, 2026
Updated
Aug 6, 2026
Reserved
Jun 6, 2025

Read the record on cve.org

Description

APR-util versions 1.6.3 (and earlier) function apr_password_validate() was not constant-time with regards to hashes or passwords comparisons, potentially leaking their content via a side channel timing attack particularly on platforms without crypt() such as  Windows, BeOS, NetWare, or Android.

Users are recommended to upgrade to version 1.6.4, which fixes this issue.

Scores

CVSSScoreVectorSource
3.17.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NCISA-ADP

Weaknesses

  • CWE-208 Observable Timing Discrepancy

Affected Products

ProductVersions
Apache Portable Runtime UtilityApache Software Foundation
  • 1.2.0 through 1.6.3Affected

References

Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.