CVE-2025-49812
Apache HTTP Server: mod_ssl TLS upgrade attack
- State
- Published
- Severity
- 7.4 High
- Published
- Jul 10, 2025
- Updated
- Nov 4, 2025
- Reserved
- Jun 11, 2025
Description
In some mod_ssl configurations on Apache HTTP Server versions through to 2.4.63, an HTTP desynchronisation attack allows a man-in-the-middle attacker to hijack an HTTP session via a TLS upgrade.
Only configurations using "SSLEngine optional" to enable TLS upgrades are affected. Users are recommended to upgrade to version 2.4.64, which removes support for TLS upgrade.
Scores
| CVSS | Score | Vector | Source |
|---|---|---|---|
| 3.1 | 7.4 High | CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N | CISA-ADP |
Weaknesses
- CWE-287 Improper Authentication
Affected Products
| Product | Versions |
|---|---|
Apache HTTP ServerApache Software Foundation |
|
References
- https://httpd.apache.org/security/vulnerabilities_24.htmlvendor-advisory
- https://lists.debian.org/debian-lts-announce/2025/08/msg00009.html
- http://www.openwall.com/lists/oss-security/2025/07/09/3
- http://www.openwall.com/lists/oss-security/2025/07/10/2
- http://www.openwall.com/lists/oss-security/2025/07/10/9
Every record here comes from the CVE Program’s CVE List. © 1999–2026 The MITRE Corporation. CVE is a registered trademark of The MITRE Corporation. The records are reproduced under the CVE Program terms of use.